Article note: #sofunny!

Redmond (dpo) - Windows wird endlich grün: Ein ab heute verfügbares Update für Windows 10 bringt nach Angaben von Microsoft erstmals Mülltrennung auf heimische PCs. Umweltschützer kritisieren schon seit Jahren, dass auf Computern alle Dateien bislang ungeachtet ihres Formats im selben Mülleimer landen. mehr...

Kompletten Artikel auf www.der-postillon.com lesen.

Seit ein paar Wochen bin ich – und das auch sehr zufriedenstellend – auf meinem Samsung Galaxy S5 Duos (klteduos) von CyanogenMod (CM) auf LineageOS (LOS) umgeschwenkt.

Vorab noch schnell, bevor es zum eigentlichen Thema geht, was dazu. – Erst nach einem full wipe läuft LOS rund. Zuerst hatte ich von CM 13 auf LOS 14.1 mit nem dirty flash (= also Beibehaltung aller Daten, bis auf Cache und Dalvik Cache) mittels TWRP aktualisiert, aber da konnte ich anfangs die zu dem Zeitpunkt aktuellen Open GApps schon nicht installieren und am Ende landete ich sogar in ner Rebootschleife …
Grundsätzlich ist eig. alles ganz einfach. – Auch ne offizielle LOS-Wikiseite gibts dazu. Oder halt auf die Schnelle:

  1. aktuelles nightly-Image von LOS für klteduos ziehen
  2. su-Modul (für Root-Rechte) für LOS ziehen (fürs klteduos die arm-Variante)
  3. Open GApps ziehen (arm, v7.1)
  4. alles auf die SD-Karte packen, so nicht eh schon dort hin herunter geladen wurde
  5. ins Recovery (TWRP) booten (wer TWRP noch nich drauf hat, kann es sich hier besorgen)
  6. Backup vom CM machen (so für den Notfall … ;-))
  7. full wip (= factory reset) machen
  8. die drei gezogenen Images/Zips nacheinander installieren (TWRP kann die auch in eine Queue packen, is ganz nett)
  9. reboot 🙂

So und nun zum Thema … – LOS benutzt (=also hat integriert) aktuell noch einige CM-Apps, so auch den CM-Dateimanager (com.cyanogenmod.filemanager, v3.0.0) und ärgerlicherweise hat der nen Bug beim Zugriff (der näml. angeblich wegen fehlender Rechte nicht geht) auf die SD-Karte.

Beim ersten Feststellen hatte ich dann iwo im Netz gefunden, dass ich die originale APK löschen und den CM-Dateimanager (als APK) neu installieren sollte. Genau weiß ich nicht mehr, ob das geklappt hatte, auf jeden Fall ging es heute (nach dem zwischenzeitl. OTA-Update eines neuen nightly, was sehr gut klappt) nicht mehr.
Also habe ich nochmal recherchiert und stolperte über o.g. Bug, in dem in einem Kommentar von Malessio am 4.2. ein kleiner Trick steht, der auch bei mir funktioniert hat.

so now i've added /mnt/media_rw/77B8-1D11 to the bookmarks and i can access the external sd-card even without root as it should

(Bitte beachten, dass 77B8-1D11 die individuelle UID der SD-Karte ist und bei jedem Device unterschiedlich ist. Bei mir gab es nur einen Ordner in /mnt/media_rw/ und mit dem klappt der Zugriff, ich habe auch noch die root-Option in den Einstellungen aktiv, auf jeden Fall jetzt problemlos …)

Am Rande: Mal schauen, wie lange der CM-Dateianager überh. noch in LOS drin sein wird. – Die Entwickler(_innen?) haben sich wohl entschieden, den nicht weiter in LOS zu integrieren. (Ich finde es schade, da mir die Alternativen – über „Downloads“, oder Einstellungen > Speicher zu gehen – zu krepelig und unzureichend erscheinen …)

In diesem Sinne: *happyflashing*! 😀

Heute war nen ‚schöner‘ verbummelter Tag …

Geschichte

Gestern Abend kommt von einem Familienmitglied die Chatnachricht „mein Rechner geht nicht mehr“, auf die ich antworte „mal Strom für mindestens eine Minute trennen“. Am Ende hilft das (nat.) nix und wir verabredeten uns für heute zu einem Telefonat.

Zu 10 Uhr dann das erste Telefonat und ich stelle recht schnell fest, dass Remote-Support ohne X und somit nur per Telefon echt ma nich geht. (Das Buchstabieren von iwelchen Kommandos ist ganz schön mühsam …)
Heraus gekommen ist immerhin, dass es sich um einen Login-Loop unter Ubuntu 16.04 (ich war anfangs noch der Meinung, dass es noch ein von mir installiertes 14.04 ist) handelt, welches seit ca. letzten Freitag besteht.

Nach ner Stunde habe ich die Faxen dicke und leider nicht mal ansatzweise ne Idee außer, dass es iwas mit der recht alten NVIDIA GeForce 6800 GS in der Aldi-Multimediakiste zu tun hat. In /var/log/Xorg.* und ~/.xsession-errors war so richtig nix zu finden.

Dann kümmerte ich mich erst einmal darum, wie ich remote auf den Desktop per SSH zugreifen kann. Dazu war es dann nötig, auf der Fritz!Box (über die der andere Rechner an INet angebunden ist) ne Portweiterleitung einzurichten und openssh-server auf dem zu reparierenden Rechner zu installieren. (Also wieder andere Baustellen …) – Das hat aber glücklicherweise dann ganz gut geklappt.

Dann hatte ich etwas Zeit (auch wenn ich nebenbei etwas HomeOffice machen ‚musste‘) zum umsehen, Loop-Ursache lokalisieren und das System noch etwas aufräumen.

Idee 1

Zuerst versuchte ich mein Glück mit dem Update des proprietären Nvidia-Treibers aus dem Paket nvidia-$NR.
Ergebnis: Ohne Erfolg, da die (alte) GeForce nur bis zum Paket nvidia-304 unterstütz wird. Also alles wieder zurückgedreht …

aptitude purge ~nnvidia- && aptitude install nvidia-304

Idee 2

Dann dachte ich mir, ich verzichte ganz auf den proprietären Kram und setze auf den (offenen) Nvidia-Treiber nouveau.
Ergebnis 2: Blöd nur dass der iwie nicht mit dem Monitor zusammenarbeiten wollte und ich nicht in der Lage war, eine annehmbare (größer 640×480) Auflösung einzustellen, obwohl ich (seit Ewigkeiten mal wieder) ne komplette /etc/X11/xorg.conf händisch gebastelt hab …
(Früher musste man alles händisch machen und Dinge haben nur geklappt, wenn man die korrekten Parameter hatte. Heute wird extrem viel automatisch gemacht und man kann oft gar nix mehr groß händisch ändern, wenn der Automatismus versagt. *grml*)

Zielgerade

Ich stieß dann (iwie in meinem 30sten Tab) auf den Foreneintrag „Anmeldung auf graphischer Oberfläche nicht möglich“ im ubuntuusers.de-Forum. Eigentlich nur, weil der recht aktuell ist. (Viele andere Recherchetreffer waren schon ewig alt …)
Der dort verlinkte Launchpad-Bug #1634802 brachte mich jedoch immer noch nicht auf die Zielgerade, jedoch auf eine Fährte. – Nämlich den (auf Ask Ubuntu verlinkten) Launchpad-Bug #1639180, der in der Beschreibung auch meine Fehlermeldung (die ich am Ende in /var/log/syslog fand) enthält:
X Error of failed request: BadValue (integer parameter out of range for operation).

Lösung

Letzten Donnerstag (3.11.16) – und da kommen wir ärgerlicherweise wieder zu Ausgangssituation .oO(Hätte ich das mal ernst genommen und in meine Recherche zu Beginn eingebunden!) – wurde die Version „304.132-0ubuntu0.16.04.2“ verteilt. Diese scheint (wie bspw. obige Bugs ja auch zeigen) einige Unzulänglichkeiten zu haben und verursachte auch auf meinem Problemsystem den Login-Loop.

Die vorhergehende Version „304.131-0ubuntu3“ lief (und läuft) ohne diese Probleme. – Ergo habe ich ein Downgrade durchgeführt.

Dazu also wieder alle installierten Nvidia-Pakete deinstallieren:

aptitude purge ~nnvidia- && aptitude install nvidia-304

Dann die „304.131-0ubuntu3“ installieren:

apt-get install nvidia-304=304.131-0ubuntu3

Am Ende noch (da das System ja nicht täglich unter meiner Kontrolle ist) die „304.131-0ubuntu3“ in der (neuen) Datei /etc/apt/preferences.d/nvidia-304 (mit folgenden Inhalt) gepinnt (s. Apt-Pinning)

Package: nvidia-304
Pin: version 304.131-0ubuntu3
Pin-Priority: 1001

Und nach nem Reboot war der Login-Loop weg … 🙂 *fertsch*

Danke an die Community, ohne die in der ja doch recht kurzer Zeit (von letztem Donnerstag bis heute) eine Lösung nicht in meinen eigenen Kräften gewesen wäre!

Old but not busted … – Dieser Inhalt wurde vor mehr als 2 Jahren publiziert. Die Korrektheit und Verfügbarkeit von Links können leider nicht gewährleistet werden.

Parallel zu LastPass probiere ich gerade seit einiger Zeit Enpass (auf meiner Ubuntu-Kiste und auf meinem Android-Handy) im Zusammenspiel mit meiner ownCloud aus. – Bis jetzt ganz gut …

Hier desh. ganz kurz ein paar Notizen zur Installation.

  1. Enpass per PPA installieren: https://www.enpass.io/kb/how-to-install-on-linux/
    Von Web Upd8 gibts auch nen schönen Artikel
  2. .desktop-Datei erstellen (s.u.)
  3. Starter-Icon herunterladen:
    wget https://upload.wikimedia.org/wikipedia/commons/c/c1/Enpass_icon.svg -O ~/.icons/Enpass.svg
  4. fertig …

# ~/.local/share/applications/Enpass.desktop
[Desktop Entry]
# https://standards.freedesktop.org/desktop-entry-spec/latest/
Version=5.2
Terminal=false
Type=Application
Name=Enpass
Comment=cross-platform password management solution
Exec=/opt/Enpass/bin/runenpass.sh
# wget https://upload.wikimedia.org/wikipedia/commons/c/c1/Enpass_icon.svg -O ~/.icons/Enpass.svg
Icon=Enpass
# https://standards.freedesktop.org/menu-spec/latest/apa.html
Categories=Security;Settings;System;Utility

Old but not busted … – Dieser Inhalt wurde vor mehr als 3 Jahren publiziert. Die Korrektheit und Verfügbarkeit von Links können leider nicht gewährleistet werden.

Vor guten vier Jahren wechselte ich von Delicious auf eine selbst gehostetes SemanticScuttle-Installation.

Seit 2013 wird SC nicht so richtig aktiv weiter entwickelt – vllt. ist es aber ja auch so fertig, wie es ist, und ja, es gibt sporadische Aktualisierungen im GitHub-Repo des Entwicklers Christian Weiske  – und über die Jahre habe ich festgestellt, dass ich die ‚semantischen Funktionalitäten‘ nicht (wirklich) benutze.

Als ich dann gestern durch Zufall beim Aktualisieren von FDroid über die Shaarlier-App stolperte und mir heute Shaarli testweise installiert hatte, war ich recht schnell entschlossen, das ca. 12 MB große SC mit dem nur 3 MB umfassende Shaarli für meine gut 2.400 Links zu ersetzen. – Gesagt, getan …

FYI: Ab heute wird bm.sok.ai mit Shaarli betrieben. – Und das sogar ganz angenehm auch unter Android …

Für die Migration der Bookmarks musste ich beim Umzug noch etwas basteln … – Das Problem an SC ist, dass es in meiner Version keinen separaten Export der öffentlichen und privaten Bookmarks erlaubt.
Also änderte ich das API-Skript etwas, um zuerst nur die publics aus SC exportieren zu können. Diese importierte ich dann in Shaarli.
Dann exportierte ich alle SC-Bookmarks und importierte diese noch einmal in Shaarli als private und ohne das Überschreiben existierender Bookmarks.
Das public export-Skript stelle ich bei Gelegenheit noch einmal hier iwo online …